Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Box View may be unavailable for some users
Incident Report for Box
Resolved
Box View has been fully restored, and we have not seen any further issues. If you experience any issues please contact us at https://support.box.com
Posted about 2 years ago. Mar 20, 2015 - 10:12 PDT
Monitoring
The issues with Box View have been resolved. Our teams will continue to monitor. If you have any issues, please contact us at https://support.box.com
Posted about 2 years ago. Mar 20, 2015 - 08:12 PDT
Update
[Correction] Box View may be unavailable for some users. Box Web Application is fully functioning.
Posted about 2 years ago. Mar 20, 2015 - 07:51 PDT
Identified
We have identified that the Box Web Application may be unavailable for some users. We are aware of the issue and working to resolve it as soon as possible.
Posted about 2 years ago. Mar 20, 2015 - 07:04 PDT
This incident affected: View API.