For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Major] Degradation of Box for Office Online

Incident Report for Box

Postmortem

We recently addressed issues affecting users’ experience with Office Online in Box. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between Aug 11, 2023 9:30 AM PT and Aug 12, 2023 4:30 AM PT, some users may have experienced difficulties while working in Box. During this time, users may have experienced infinite loading when trying to view or edit a PowerPoint file in Box with the Office Online editor.

Analysis

This issue occurred as a result of a bug that was a introduced by a recent Microsoft code change. Microsoft was able to resolve the issue by releasing a bug fix, which addressed the issue for Box users. In addition, we are working to improve our early detection and communication to prevent similar issues from occurring in the future.

Corrective Actions

The following corrective actions have been completed or are planned:

  • Improved alerts and monitoring of Office Online traffic

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,
The Box Team

Posted Sep 21, 2023 - 09:56 PDT

Resolved

Microsoft has confirmed that the issue has been resolved. Box for Office Online Powerpoint is now recovered and no additional impact has been observed. If you are encountering any issues, please contact Box Support at https://support.box.com.
Posted Aug 12, 2023 - 14:08 PDT

Investigating

We are experiencing an issue with our Office Online Integration. When attempting to open Office Online Powerpoint files with the web editor users are met with a loading screen blocking the ability to make edits. Microsoft have confirmed that the issue extends beyond Box and are currently investigating.
Posted Aug 11, 2023 - 21:55 PDT
This incident affected: Partners / Integrations (Microsoft Online).