On October 1, 2018 Box changed the metholodoly for sharing service updates to include issues with minor customer impact in an effort to provide greater transparency and faster notifications. Read about the changes here...

[Minor] Issue with Uploads
Incident Report for Box
Resolved
The monitoring period has ended and no further impact has been observed. We are considering this issue resolved. If you are still experiencing issues with uploads, please let us know at https://support.box.com.
Posted 14 days ago. Nov 01, 2018 - 12:01 PDT
Monitoring
We have identified the cause of the issue and taken steps to remediate with full recovery observed around 11:05 AM PST. We are currently monitoring to ensure no further impact from this event.
Posted 14 days ago. Nov 01, 2018 - 11:15 PDT
Investigating
We are currently investigating an issue with uploads. Some users may experience latency when uploading content. We will provide more information here as it becomes available.
Posted 14 days ago. Nov 01, 2018 - 10:59 PDT