Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

[RESOLVED] Box Web Application may be unavailable for some users
Incident Report for Box
Resolved
No further issues have been observed while monitoring. If you have any problems, please contact us at https://support.box.com
Posted over 1 year ago. Jun 10, 2015 - 00:05 PST
Monitoring
The Box Web Application was restored at 6:53 PM PDT, and has been fully functional. We will continue to monitor. If you have any issues, please contact us at https://support.box.com
Posted over 1 year ago. Jun 09, 2015 - 19:18 PST
Investigating
We have identified that the Box Web Application may be unavailable for some users. We are aware of the issue and working to resolve it as soon as possible.
Posted over 1 year ago. Jun 09, 2015 - 18:29 PST
This incident affected: Box Website.