On October 1, 2018 Box changed the metholodoly for sharing service updates to include issues with minor customer impact in an effort to provide greater transparency and faster notifications. Read about the changes here...

Degradation of Box for Office Online
Incident Report for Box
Resolved
Our monitoring period following resolution has ended, and no further impact to the Box for Office Online integration has been observed. Thanks for your patience during our investigation and resolution process.

If you continue to experience any issues, please contact Box User Services at https://support.box.com
Posted 5 months ago. Jun 11, 2018 - 18:02 PDT
Monitoring
We have resolved the issue affecting the Box for Office Online integration. Users of the integration should be able to edit .xlsx files concurrently without receiving any errors.

We are continuing to monitor the the integration to ensure no further impact is observed.
Posted 5 months ago. Jun 11, 2018 - 17:44 PDT
Update
Thanks for your patience while we resolve the issue with the Box for Office Online integration!

Our release for this fix is still in progress. Some users may be able to concurrently edit .xlsx files again. We will provide another update in 1 hour or at the next status change.
Posted 5 months ago. Jun 11, 2018 - 16:25 PDT
Update
We are continuing efforts to restore full functionality to the Box for Office Online integration. We are in the process of releasing a fix for this issue.

We will provide another update in 1 hour or at the next status change. Thanks for your patience!
Posted 5 months ago. Jun 11, 2018 - 15:15 PDT
Update
We are continuing efforts to restore full functionality to the Box for Office Online integration. We are in the process of releasing a fix for this issue.

Users of this service may continue to receive a "Can't Edit Workbook" alert when attempting to edit Excel files with the Box for Office Online integration while the release is in progress.

We will provide another update in 1 hour or at the next status change.
Posted 5 months ago. Jun 11, 2018 - 14:07 PDT
Update
We are continuing remediation efforts to restore full functionality to the Box for Office Online integration.

We will provide another update in 1 hour or at the next status change. Thanks for your patience!
Posted 5 months ago. Jun 11, 2018 - 13:43 PDT
Identified
We are continuing remediation efforts to restore full functionality to the Box for Office Online integration.

Users of this service may continue to receive a "Can't Edit Workbook" alert when attempting to edit Excel files with the Box for Office Online integration while remediation is in process. Impact is limited to concurrent editing of .xlsx files. We will provide another update in 1 hour or at the next status change.
Posted 5 months ago. Jun 11, 2018 - 12:33 PDT
Update
We are continuing to investigate reports of an intermittent issue with the Box for Office Online integration.

Users of this service may receive a "Can't Edit Workbook" alert when attempting to edit Excel files with the Box for Office Online integration. Impact is limited to concurrent editing of .xlsx files. We will provide another update in 1 hour or at the next status change.
Posted 5 months ago. Jun 11, 2018 - 11:17 PDT
Update
We are continuing to investigate this issue.
Posted 5 months ago. Jun 11, 2018 - 10:39 PDT
Investigating
We are investigating reports of an intermittent issue with the Box for Office Online integration. Users of this service may receive a "Can't Edit Workbook" alert when attempting to edit Excel files with the Box for Office Online integration. Affected services are subject to change as the investigation continues.
Posted 5 months ago. Jun 11, 2018 - 10:31 PDT