The scheduled maintenance has been completed. Please contact Box Support via https://support.box.com if you experience any issues.
Posted Jan 08, 2025 - 11:34 PST
In progress
The scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 08, 2025 - 10:16 PST
Scheduled
Starting on Wednesday, January 8th at 9:30 AM PST until 11:30 AM PST, Box will be conducting Resiliency Testing. This may result in short and intermittent service degradations, such as brief slowness while using the box.com website, client applications, and API. We will be closely monitoring service metrics and do not expect an increase in 5xx errors during this window. As a result of this testing, we aim to update and enhance our recovery capabilities, ultimately improving the user experience and providing a smoother, more efficient platform by ensuring the reliability and resiliency of our services. We apologize for any inconvenience this may cause and greatly appreciate your understanding as we strive to enhance our services. Any additional updates will continue to be shared through our status site until this maintenance is complete. If you require any additional assistance during this maintenance, please contact Box Support via https://support.box.com.
Posted Dec 19, 2024 - 11:17 PST
This scheduled maintenance affected: Box Platform / API (Content API, Content Preview, Search, Uploads/Downloads), Box Notes (Web Application), Desktop Applications (Box Sync, Box Drive), Box Web Application (Uploads/Downloads, Collaboration, Search, Preview), and Mobile Applications (Preview, Search, Uploads/Downloads).