For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Major] Issues with generating Content Preview
Incident Report for Box
Postmortem

We recently addressed issues affecting conversion latencies for Sharepoint or Microsoft Excel files. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between November 15, 2022 at 7:12 am PST and November 16, 2022 at 3:04 am PST, some users may have experienced difficulties while working in Box. During this time, customers may have experienced preview conversion latencies for Sharepoint or Microsoft Excel files. The issue occurred as a result of a reduction of available conversion capacity as part of ongoing data center migrations. We were able to resolve the issue by provisioning additional capacity in their place. In addition, operational process and tooling will be implemented to prevent similar issues from occurring in the future. 

Analysis

As part of a data center migration, hosts for the conversion service were removed from production before replacement capacity was brought online, resulting in a 15% loss to conversion capacity. The capacity loss and root cause were identified right away and additional capacity was brought online to compensate.

Corrective Actions

The following corrective actions have been completed or are planned:

  • Process updates have been enabled to better facilitate communication between Infrastructure and Capacity teams to minimize the likelihood of similar issues occurring in the future.
  • Changes to automation for the validation of capacity requests have been enacted.
  • Canary rollout of windows related changes for the conversion service will be enabled.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,
The Box Team

Posted Dec 08, 2022 - 10:16 PST

Resolved
This incident has been resolved.
Posted Nov 16, 2022 - 08:02 PST
Update
We are continuing to monitor for any further issues.
Posted Nov 15, 2022 - 23:45 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 15, 2022 - 22:16 PST
Update
We are continuing to investigate this issue.
Posted Nov 15, 2022 - 20:10 PST
Update
We are continuing to investigate this issue.
Posted Nov 15, 2022 - 19:13 PST
Investigating
We are currently investigating an issue where users are experiencing a degraded previewing experience. Our team has identified the root cause of this issue and we are working on recovery of the impacted service.
Posted Nov 15, 2022 - 17:01 PST
This incident affected: Box Web Application (Preview).