About this Site
You trust Box as a valued service provider and partner. You should also trust us to let you know when something is being impacted. With this in mind, we're adopting new practices around communicating service interruptions and outages to keep you informed of what's happening with and within the Box Services. Learn more...

Some users may be experiencing intermittent issues accessing Box
Incident Report for Box
Resolved
The monitoring period for this issue has ended and no further impact has been observed. If you continue to see any issues, please contact our Box User Services team at https://community.box.com/t5/Contact-Support/ct-p/BoxSupport.
Posted 9 months ago. Jan 12, 2018 - 13:22 PST
Monitoring
Box Engineering has identified and resolved the issues impacting intermittent connectivity issues to Box. Users should be able to access Box at this time. Box Engineering will monitor to ensure no further impact is observed.
Posted 9 months ago. Jan 12, 2018 - 11:54 PST
Update
Box Engineering continues to investigate an issue related to intermittent connectivity issues to Box. Some users may be unable to login to Box.com and/or may be experiencing longer than usual page load times and intermittent upload issues.
Posted 9 months ago. Jan 12, 2018 - 10:48 PST
Investigating
Box Engineering is investigating an issue related to intermittent connectivity issues to Box. Some users may be unable to login to Box.com or may be experiencing longer than usual load times.
Posted 9 months ago. Jan 12, 2018 - 09:47 PST