On October 1, 2018 Box changed the methodology for sharing service updates to include issues with minor customer impact in an effort to provide greater transparency and faster notifications. Read about the changes here...

[Medium] Issue with Uploads and Downloads
Incident Report for Box
Resolved
We have completed our monitoring period and are considering the issue fully resolved. If you are seeing any new issues, please let us know at https://support.box.com.
Posted about 1 month ago. Feb 07, 2019 - 10:08 PST
Monitoring
We have completed our investigation and will actively monitor to ensure that there is no further impact. Next update in 30 minutes.
Posted about 1 month ago. Feb 07, 2019 - 09:35 PST
Identified
We have identified the cause of the issue and remediated the impact. During the time of this issue, users may have also seen issues with previewing, delays with search indexing, and delays with webhooks and Box Skills event notifications. As of approximately 8:30 AM Pacific, users should no longer see any delays or errors in taking the affected actions.
Posted about 1 month ago. Feb 07, 2019 - 08:44 PST
Update
We are continuing to investigate the issue with uploads and downloads. Users may also experience slow navigation within the web application and execution delays with Workflow/Automation policies.
Posted about 1 month ago. Feb 07, 2019 - 08:19 PST
Investigating
We are currently investigating an issue with uploads and downloads beginning at approximately 7:20 AM Pacific time. Users may see errors while uploading or downloading. We will provide updates here as soon as possible.
Posted about 1 month ago. Feb 07, 2019 - 07:44 PST
This incident affected: Box Web Application (Uploads/Downloads, Search, Preview, Workflows and Automations), Box Platform / API (Content Preview, Search, Uploads/Downloads), and Mobile Applications (Uploads/Downloads).