For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Minor] Issues with Uploads

Incident Report for Box

Postmortem

We recently addressed issues affecting file uploads and edits that create new file versions. We want to explain what happened and what we have done to prevent it from happening again.

Between Jul 26, 2026 4:38 PM PDT and Jul 28, 2026 10:34 AM PDT, some users may have experienced delays or failures when uploading files or saving edits that create new file versions. The impact was limited to cases with a high number of concurrent uploads or edits on the same file.

During this period, concurrent upload and edit traffic contended on shared database locks while creating new file versions. Under load, an overly conservative insert locking strategy acquired locks, creating a bottleneck in the database. The contention was amplified by background processes that post-process the uploaded file and attach additional information to every new version, competing for the same locks.

Analysis

This incident highlighted several opportunities for improvement:

  • Lock-wait failures do not appear in our usual change-stream / mutation telemetry, which delayed our investigation.
  • Background processes can contend with upload and edit paths that create new versions. Our development environments did not fully test this particular interaction under load.

Remediation combined an immediate reduction in non-essential background scan load with a code change that relaxed the overly conservative locking behavior, while preserving the intended isolation guarantees.

Corrective Actions

Box has initiated the following corrective actions:

  • Deploy and validate the insert-behavior fix across all live clusters (completed and confirmed).
  • Improve observability for lock-wait and timeout-driven load so contention sources are visible.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter.

Sincerely,

The Box Team

Posted Aug 04, 2026 - 16:00 PDT

Resolved

After further monitoring, this incident is now considered resolved. Box services have been restored to full functionality. Please contact Box Support at https://support.box.com/ if you continue to experience any issues.
Posted Jul 27, 2026 - 21:57 PDT

Monitoring

Our team has taken steps to remediate this issue and is seeing improvements. We are continuing to monitor for any additional impact.
Posted Jul 27, 2026 - 21:22 PDT

Update

We are continuing to work on a fix for this issue.
Posted Jul 27, 2026 - 21:02 PDT

Identified

Our team has identified the underlying cause of this issue and is working to take remediating steps. We will provide additional updates as they become available.
Posted Jul 27, 2026 - 20:08 PDT

Investigating

We are investigating an ongoing issue affecting uploads. We will provide more information as soon as it is available.
Posted Jul 27, 2026 - 19:58 PDT
This incident affected: Box Web Application (Uploads/Downloads).