For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Minor] Issue with Multiple Box Services
Incident Report for Box
Postmortem

We recently addressed issues affecting All Files and Search. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between October 10, 2024 1:34am and October, 10 2024 7:45pm PST, some users may have experienced difficulties while working in Box. During this time, some users might have noticed latencies accessing All Files and Search. The issue occurred because of an unusual sequence of customer activity that caused load on multiple backend systems. We were able to resolve the issue by increasing capacity of the impacted internal applications. In addition, we have improved our monitoring processes and implemented new monitors to prevent similar issues from occurring in the future.

Analysis

Starting October 10 2024 1:34am PST, an unusual sequence of customer activity occurred that put load on multiple backend systems and hence resulting in the degradation. Various applications were scaled up in the process to support the increased load.

Corrective Actions

Box has initiated the following corrective actions:

  • Scaled up various applications to support the increased load.
  • Evaluate changes required to prevent this from happening again.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,

The Box Team

Posted Oct 30, 2024 - 06:07 PDT

Resolved
After further monitoring, this incident is now considered resolved. Our teams have validated that all affected services are restored to full functionality. Please contact Box Support at https://support.box.com/ if you continue to experience any issues.
Posted Oct 10, 2024 - 02:43 PDT
Monitoring
Our team has taken steps to remediate this issue and is seeing improvement in the affected services of SSO Login, Search and All Files page accessibility. The services should be returned to full functionality now. We are continuing to monitor for any additional impact.
Posted Oct 10, 2024 - 02:27 PDT
Identified
Our team has identified an issue where customers may have noticed performance issues while logging in via SSO and accessing the All Files page and utilising the Search between 01:07 to 01:40 PDT. The affected services are now functional. We are currently investigating what triggered this. We will provide additional updates as they become available.
Posted Oct 10, 2024 - 02:10 PDT
This incident affected: Box Web Application (Login/SSO, Search, Accessible Site (a.box.com)) and Box Platform / API (Search).