[Minor] Issues with Box Sign

Incident Report for Box

Issue Summary

We recently addressed issues affecting Box Sign. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between 8:20 AM and 11:20 AM PDT on April 29, 2024, some users may have experienced difficulties while working in Box Sign. During this time, the Box Sign service experienced performance slowdowns. The issue occurred as a result of a failure within the network stack, which was resolved by adjusting the network configuration. In addition, we are working to enhance service reliability to prevent similar issues from occurring in the future. 

Analysis

Box Sign backend uses a cloud-based network setup which is composed of various network components. Under increased load, some of the network components experienced scaling issues, which resulted in a network performance degradation for the app.

Corrective Actions

The following corrective actions have been completed or are planned:

  • Update the scaling configuration of the network components
  • Update the configuration of network-intensive application dependencies

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,

The Box Team

Posted 11 months ago. May 15, 2024 - 10:00 PDT

Resolved

After further monitoring, this incident is now considered resolved. Box Sign has been restored to full functionality. If you continue to experience any issues, please contact Box Support at https://support.box.com.
Posted 11 months ago. Apr 29, 2024 - 12:30 PDT

Monitoring

Our team has taken steps to remediate this issue and is seeing improvement for Box Sign. We are continuing to monitor for any additional impact.
Posted 11 months ago. Apr 29, 2024 - 11:41 PDT

Identified

Our team has identified the underlying cause of this issue and is working to take remediating steps. We will provide additional updates as they become available.
Posted 11 months ago. Apr 29, 2024 - 11:27 PDT

Investigating

We are investigating an ongoing issue with Box Sign. Customers may experience timeouts or slowness using Box Sign in the Box Web Application. We will provide more information as soon as it is available.
Posted 11 months ago. Apr 29, 2024 - 10:43 PDT
This incident affected: Box Web Application (Box Sign).