For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Major] Some customers can have issues to load or open MS Office Online

Incident Report for Box

Postmortem

We recently addressed issues affecting the Box For Office Integration. We would like to take the opportunity to further explain these issues and the steps taken to keep them from happening again.

Between 01:39 AM PT and 05:19 AM PT on March 12, 2025, some users may have experienced difficulties while working in Box. During this time, Box customers were unable to open or edit Microsoft Office files via Office Online. The issue occurred as a result of network connectivity issues with Microsoft's services. We were able to resolve the issue by restoring the network connectivity with our partner. In addition, we are working on making the Box For Office Integration more resilient to prevent similar problems in the future.

Analysis

The Box For Office Integration enhances communication with Microsoft servers, enabling Office Online functionalities for files hosted in Box. This communication occurs through the Web Application Open Platform Interface (WOPI) protocol. Most WOPI operations require a process called WOPI discovery. During this phase, a WOPI host (like Box), identifies how to perform specific actions within the WOPI protocol. In this case, it is performed by retrieving a discovery XML file from Microsoft's Discovery Endpoint. This file contains essential information about the URLs needed for these actions and the keys required for validating signatures on each WOPI command. The file is then cached for a set period.

Before the outage that caused this issue, one of the discovery endpoints in Office Online faced significant slowdowns and longer response times than usual. At the same time, Box's cache expired, which prevented us from managing WOPI operations effectively. As a result, users may have experienced session terminations and disruption of the integration between the two services.

Corrective Actions

Box has initiated the following corrective actions:

  • The cache time-to-live for the discovery file will be increased to minimize Box's exposure to potential failures in reaching the discovery endpoint.
  • The discovery file will be periodically refreshed by a dedicated process. This approach aims to offload the operational endpoint, thereby minimizing its exposure to potential issues during periods of degradation.
  • The operations timeout will be reduced to enhance overall performance.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,
The Box Team

Posted Apr 03, 2025 - 02:58 PDT

Resolved

After further monitoring, this incident is now considered resolved. MS Office Onlive Service has been restored to full functionality. If you continue to experience any issues, please contact Box Support at https://support.box.com.
Posted Mar 12, 2025 - 06:00 PDT

Monitoring

Our team has taken steps to remediate this issue and is seeing improvement for MS Office Online service. We are continuing to monitor for any additional impact.
Posted Mar 12, 2025 - 05:45 PDT

Update

Our team has identified the underlying cause of this issue with MS Office Online. The problem is located at Microsoft only. We are working with them to resolve it as quickly as possible. We will provide additional information as it becomes available.
Posted Mar 12, 2025 - 05:39 PDT

Update

Our team has identified the underlying cause of this issue with MS Office Online. The problem is located at Microsoft only. We are working with them to resolve it as quickly as possible. We will provide additional information as it becomes available.
Posted Mar 12, 2025 - 05:07 PDT

Identified

Our team has identified the underlying cause of this issue with MS Office Online. The problem is located at Microsoft only. We are working with them to resolve it as quickly as possible. We will provide additional information as it becomes available.
Posted Mar 12, 2025 - 04:38 PDT

Update

Our team is investigating an issue with MS Office Online. Users may see errors or slowness when attempting to open MS Office files through MS Office Online. We will provide additional information as it becomes available.
Posted Mar 12, 2025 - 04:07 PDT

Investigating

Our team is investigating an issue with MS Office Online. Users may see errors or slowness when attempting to open MS Office files through MS Office Online. We will provide additional information as it becomes available.
Posted Mar 12, 2025 - 03:44 PDT
This incident affected: Partners / Integrations (Microsoft Online).