For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Medium] Issue with Multiple Box Services

Incident Report for Box

Resolved

After further monitoring, this incident is now considered resolved. The affected services have been restored to full functionality. If you continue to experience any issues, please contact Box Support at https://support.box.com.
Posted Jun 10, 2026 - 19:01 PDT

Monitoring

Our team has taken steps to remediate this issue and is seeing improvement. We are continuing to monitor for any additional impact.
Posted Jun 10, 2026 - 18:41 PDT

Identified

Our team is investigating an issue with Box API authentication and has identified the underlying cause of this issue and is working to take remediating steps. We will provide additional updates as they become available.
Posted Jun 10, 2026 - 17:34 PDT
This incident affected: Desktop Applications (Login/SSO, Box Edit / Tools) and Box Platform / API (Authentication (OAuth 2.0 / JWT), Box Sign).