Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Degradation of Box Notes and Box Relay
Incident Report for Box
Resolved
The extended monitoring period for this issue has ended and no additional impact has been observed. If you are still experiencing issues with Box Notes or Box Relay, please reach out to our User Services team at https://support.box.com
Posted 3 months ago. Apr 05, 2018 - 17:15 PDT
Monitoring
Box Engineering has resolved the issue with the Box Notes and Relay and is entering an extended monitoring period to ensure no further impact is observed.
Posted 3 months ago. Apr 05, 2018 - 14:46 PDT
Investigating
Box is investigating reports of an issue impacting Box Notes and Box Relay. Users may be unable to access these endpoints at this time. Affected services are subject to change as the investigation continues.
Posted 3 months ago. Apr 05, 2018 - 13:56 PDT
This incident affected: Box Notes and Box Relay.