For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Minor] Issue With EMM Logins
Incident Report for Box
Postmortem

We recently addressed issues affecting Mobile EMM Tier 1 logins. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between January 18, 2022, 2:00 PM PST and January 19, 2022, 1:42 AM PST, some users may have experienced difficulties while working in Box. During this time, a subset of users utilizing Box for EMM may have encountered an error while attempting to log on. The issue occurred as a result of a configuration change that resulted in customers using EMM being unable to authenticate to Box. We were able to resolve the issue by reverting the change.

Analysis 

The impacted back-end service accesses encrypted content from Box’s database by use of an encryption key. This key was previously supplied from our configuration system. Recently, Box migrated certain keys and other sensitive information to a different system. This migration resulted in a misconfiguration, which caused the service to be unable to properly read the key. As a result, a subset of customers may have experienced errors while attempting to log on.

Corrective Actions

The following corrective actions have been completed or are planned:

  • Improving Mobile EMM testing processes
  • Enabling infrastructure to test EMM use cases in internal environments
  • Improving alerting and monitoring capabilities of critical mobile services
  • Making improvements to the back-end service to handle custom key-names and improve error messaging to help diagnose issues faster

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,
The Box Team

Posted Jan 28, 2022 - 08:34 PST

Resolved
From January 18th at 1:40pm to January 19th at 1:40am PT, some users utilizing Box for EMM may have encountered an error during the login attempt. Our team has taken actions to remediate this behavior and no additional impact has been observed. If you are still encountering any issues with Box for EMM, please contact us at https://support.box.com.
Posted Jan 18, 2022 - 13:30 PST