Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Users Unable to View Cases on the Box Community
Incident Report for Box
Resolved
We have resolved all issues related to viewing cases in the Box Community. Thank you for your patience as we worked to resolve this issue.
Posted 6 months ago. Sep 21, 2016 - 20:04 PDT
Identified
Working with our third-party provider, we have identified the source of the issue preventing the viewing of cases within the Box Community. We are executing a plan to restore access to this functionality as soon as possible.
Posted 6 months ago. Sep 21, 2016 - 19:04 PDT
Update
While new case submissions are no longer impacted, we continue to work with a third-party service to remediate issues viewing cases in the Box Community.
Posted 6 months ago. Sep 21, 2016 - 13:05 PDT
Investigating
When attempting to view an existing or submit a new support case through the Box Community, some users may receive an error and will unable to proceed further. This is directly impacted by an issue with a third-party provider with whom we are actively engaged to resolve.
Posted 6 months ago. Sep 21, 2016 - 08:05 PDT