About this Site
You trust Box as a valued service provider and partner. You should also trust us to let you know when something is being impacted. With this in mind, we're adopting new practices around communicating service interruptions and outages to keep you informed of what's happening with and within the Box Services. Learn more...

Some users may be experiencing issues accessing Box
Incident Report for Box
Resolved
The monitoring period for this issue has ended and no further impact has been observed. If you continue to see any issues, please contact our Box User Services team at https://community.box.com/t5/Contact-Support/ct-p/BoxSupport.
Posted 10 months ago. Jan 05, 2018 - 14:01 PST
Monitoring
Box Engineering has identified and resolved the issues impacting connectivity to Box. Users should be able to access Box at this time. Box Engineering will continue to monitor to ensure no further impact is observed.
Posted 10 months ago. Jan 05, 2018 - 13:31 PST
Investigating
Box Engineering is investigating an issue related to intermittent connectivity issues to Box. Some users may be unable to login to Box.com or may be unable to upload files to Box.
Posted 10 months ago. Jan 05, 2018 - 13:07 PST