Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Some users may be experiencing issues loading Admin Console
Incident Report for Box
Resolved
The monitoring period for this issue has ended and no further issues have been observed. Please report any issues to Box User Services via https://community.box.com/help
Posted over 1 year ago. Jun 14, 2016 - 12:31 PDT
Monitoring
Box engineers have stabilized all services. We're currently monitoring to ensure there is no further impact from this event.
Posted over 1 year ago. Jun 14, 2016 - 11:11 PDT
Identified
Some users may be experiencing issues with loading the Admin Console. Our engineers have identified the source of the issue and are working to resolve it.
Posted over 1 year ago. Jun 14, 2016 - 09:26 PDT
This incident affected: Box Website.