Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Some users may experience an issue with Box Relay
Incident Report for Box
Resolved
Box Relay is up and now operational. No further impact has been observed. Our apologizes for the inconvenience! If you continue to experience any further issues with Box Relay, please contact us at: https://support.box.com
Posted 21 days ago. Jul 26, 2018 - 23:20 PDT
Investigating
We are currently investigating an issue with Box Relay. Impacted users of this product will see an alert that reads: "The service is currently degraded or unavailable. Please report this service interruption to your administrator or try again later." As a result, functionality to create or update workflows and tasks is currently available. We will continue to provide updates as the investigation continues.
Posted 21 days ago. Jul 26, 2018 - 20:58 PDT
This incident affected: Box Relay.