For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[RESOLVED] Box Web Application Unavailable
Incident Report for Box
Resolved
Starting approximately around 11:09PM Pacific on August 11, the Box site was inaccessible for some users. Engineering Teams resolved the issue and have observed no further impact at this time.
Posted Aug 11, 2015 - 23:09 PDT