Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Uploads and Downloads degraded.
Incident Report for Box
Resolved
As of 12:48 PDT, the issue with intermittent uploads and downloads is resolved.
Posted over 2 years ago. Sep 17, 2014 - 12:48 PDT
Investigating
We are still investigating the issue with intermittent uploads and downloads.
Posted over 2 years ago. Sep 17, 2014 - 12:47 PDT
Monitoring
Some users may have experienced degraded uploads/ downloads between 8:42am - 8:45am PDT.
Posted over 2 years ago. Sep 17, 2014 - 09:40 PDT
This incident affected: Downloads and Uploads.