For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Major] Issue with Payment Processing

Incident Report for Box

Postmortem

We recently addressed issues impacting some individuals signing up for a Box account. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between May 15, 2025 12:19 AM PDT and May 16, 2025 5:45 AM PDT, some users may have experienced difficulties while signing up for Box. During this time, some users were presented with a message incorrectly indicating a payment processing issue during the signup process. The issue occurred as a result of a recent code change to update error messages. We were able to resolve the issue by updating the message and removing the one that incorrectly identified the issue as being related to payment. Additionally, we’re improving our planning and testing strategies to prevent similar issues from occurring in the future. 

Analysis

The signup issues occurred as a result of new security measures adopted to better protect our users and prevent misuse. The new security measures included changes to our error messaging. Some of the error messages shown during free user signups inadvertently included incorrect wording after this change resulting in some confusion. We have now updated these messages to be clearer and more accurate based on the customer signup flow.

Corrective Actions

Box has initiated the following corrective actions:

  • Ensuring error messages are customized and correct for different user segments to prevent confusion.
  • Maintaining close collaboration between engineering, product, and customer support teams to quickly identify and address any user-facing issues arising from backend changes.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,
The Box Team

Posted May 29, 2025 - 11:54 PDT

Resolved

After further monitoring, this incident is now considered resolved. Payment Service has been restored to full functionality. If you continue to experience any issues, please contact Box Support at https://support.box.com.
Posted May 15, 2025 - 05:08 PDT

Identified

Our team has identified the underlying cause of this issue and is working to take remediating steps. We will provide additional updates as they become available.
Posted May 15, 2025 - 04:56 PDT

Update

Our team is investigating an issue with Billing. Users attempting to process payment on their Box account could receive error messages. We will provide additional information as it becomes available.
Posted May 15, 2025 - 03:15 PDT

Update

Our team is investigating an issue with Billing. Users attempting to process payment on their Box account could receive error messages. We will provide additional information as it becomes available.
Posted May 15, 2025 - 02:13 PDT

Update

Our team is investigating an issue with Billing. Users attempting to process payment on their Box account could receive error messages. We will provide additional information as it becomes available.
Posted May 15, 2025 - 01:47 PDT

Investigating

Our team is investigating an issue with Billing. Users attempting to process payment on their Box account could receive error messages. We will provide additional information as it becomes available.
Posted May 15, 2025 - 00:57 PDT
This incident affected: Box Web Application (Admin Console & Functionality).