For more informtion about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Critical] Issue with Box Notes
Incident Report for Box
Postmortem

NOTICE AND DISCLAIMER: CUSTOMER UNDERSTANDS AND AGREES THAT THIS IS PRELIMINARY INFORMATION SUBJECT TO FURTHER REVIEW AND ANALYSIS BY BOX. TO THE BEST OF OUR KNOWLEDGE, THIS IS THE CURRENT STATE AND WILL BE UPDATED AS MORE INFORMATION IS CONFIRMED.

LAST UPDATED: APRIL 29, 2020

We recently addressed issues affecting Box Notes. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.
 
Between 7:26am and 8:36am on April 8th, 2020, some users may have been unable to view and edit Box Notes. During this time, Box Notes may not have loaded properly and some Box Notes that had previously been opened were disconnected. The issue occurred as a result of a latency spike within the Box Notes network load balancing layer. The issue was resolved after implementing latency-related configuration changes and performing hardware resets. In addition, we are working to both increase the availability of the network load balancing layer and also upgrade the software the servers in that layer rely on. We have also improved our testing and alerting processes to prevent similar issues from occurring in the future.
 
We are continuously working to improve Box and want to make sure we are delivering the best product and user experience. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter.

Sincerely,
The Box Team

Posted Apr 29, 2020 - 20:26 PDT

Resolved
This incident has been resolved.
Posted Apr 08, 2020 - 11:16 PDT
Update
This incident is now considered Resolved. Please contact Box Support at https://support.box.com if you experience any additional issues.
Posted Apr 08, 2020 - 11:10 PDT
Identified
Our team has identified the cause of this behavior and is actively taking steps to remediate impact. We will continue to provide additional updates as they become available.
Posted Apr 08, 2020 - 09:44 PDT
Investigating
We are currently investigating an issue where Box Notes is not loading as expected. We will provide additional updates as they become available.
Posted Apr 08, 2020 - 08:15 PDT
This incident affected: Box Notes (Web Application, Desktop Client).