For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Minor] Issues with Box Notes
Incident Report for Box
Postmortem

We recently addressed issues affecting Box Notes. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between 2:41 PM PT on August 22, 2023 and 7:30 AM PT on August 23, 2023, some users may have experienced difficulties while working in Box. During this time, some users may not have been able to view certain images embedded inside Box Notes. The issue occurred as a result of a recent code change in our ongoing effort to improve performance and stability. We were able to resolve the issue by reverting the faulty change. In addition, In addition, we are working to improve our testing and deployment processes to prevent similar issues from occurring in the future. 

Analysis

The issue was caused by a change in the configuration of the server fleet responsible for processing Box webapp traffic. The change was aimed at consolidating configurations such that further reliability and user experience improvements can be developed and deployed faster in the future. Unfortunately, the change inadvertently impacted embedded image rendering in Box Notes, which caused some customers to experience difficulty viewing images embedded in Box Notes. Additionally, the testing conducted as part of our standard deployment process did not address this specific facet of Box Notes, and as a result, this issue was not detected prior to deployment. Additionally, incident detection and mitigation took longer than normal because there was no alert configured to escalate in case of failed embedded image renders in Box Notes.

Corrective Actions

The following corrective actions have been completed or are planned:

  • Implement automated testing for Box Notes embedded image rendering
  • Add alerts for Box Notes embedded image render failures

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,

The Box Team

Posted Sep 22, 2023 - 10:04 PDT

Resolved
After further monitoring, this incident is now considered resolved. Box services have been restored to full functionality. Please contact Box Support at https://support.box.com/ if you continue to experience any issues.
Posted Aug 23, 2023 - 08:08 PDT
Monitoring
Our team has taken steps to remediate this issue and our Box Notes service should be returned to full functionality. We are continuing to monitor for any additional impact.
Posted Aug 23, 2023 - 05:50 PDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 23, 2023 - 03:37 PDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 22, 2023 - 22:40 PDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 22, 2023 - 21:49 PDT
Identified
Box continues remediation efforts to restore full functionality to Box Notes.

Users of this service may continue to experience issues loading images in Box Notes while remediation is in process.
Posted Aug 22, 2023 - 21:02 PDT
Investigating
We are investigating an ongoing issue affecting images not loading in Box Notes. We will provide more information as soon as it is available.
Posted Aug 22, 2023 - 19:59 PDT
This incident affected: Box Notes (Web Application).