Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Creating shared links
Incident Report for Box
Resolved
The monitoring period has ended and no further impact has been observed. If you continue to experience any issues, please contact the Box User Services team via https://community.box.com/help
Posted about 1 month ago. Jan 18, 2017 - 19:30 PST
Monitoring
Creating shared links and adding images to Box Notes has been restored. Box engineering teams are continuing to monitor services to ensure no further impact.
Posted about 1 month ago. Jan 18, 2017 - 17:41 PST
Identified
Users may also have difficulty adding images to Box Notes.
Posted about 1 month ago. Jan 18, 2017 - 16:35 PST
Investigating
We are investigating reports of customers not being able to create shared links.
Posted about 1 month ago. Jan 18, 2017 - 16:10 PST
This incident affected: Box Website, Box Notes, and Sharing.