Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

[RESOLVED] Box Web Application may be unavailable for some users
Incident Report for Box
Resolved
We have not seen any further issues. At this time we believe it to be fully resolved. If you experience any problems, please contact us at https://support.box.com
Posted over 2 years ago. Jul 07, 2015 - 19:47 PDT
Monitoring
Box Web Application fully stabilized at 17:45 PDT. We will continue to monitor. If you run into any issues, please feel free to reach out to us at https://support.box.com
Posted over 2 years ago. Jul 07, 2015 - 18:13 PDT
Investigating
We have identified that the Box Web Application may be intermittent for some users. We are aware of the issue and working to resolve it as soon as possible.
Posted over 2 years ago. Jul 07, 2015 - 17:40 PDT
This incident affected: Box Website.