About this Site
You trust Box as a valued service provider and partner. You should also trust us to let you know when something is being impacted. With this in mind, we're adopting new practices around communicating service interruptions and outages to keep you informed of what's happening with and within the Box Services. Learn more...

Some Users Unable to View Existing Support Cases
Incident Report for Box
Resolved
Our third-party integrator reverted a change and access to view cases from the Community Site has been restored.
Posted 12 months ago. Nov 10, 2017 - 10:24 PST
Identified
We have identified a problem impacting users viewing existing support cases from our Community Site, https://community.box.com. When attempting to view a case the following message is displayed "We're unable to find the case. If you believe this to be an error or need to submit a new case, please click here." The root cause has been identified and our teams are escalating the concern to a third-party integrator to remediate.
Posted 12 months ago. Nov 10, 2017 - 09:07 PST