Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

High Latency Causing Long Load Times to Box
Incident Report for Box
Resolved
High latency resulting in slower access to Box has been fully resolved since 1 PM PDT. If you are experiencing issues, please contact us at https://support.box.com.
Posted about 2 years ago. Mar 30, 2015 - 15:59 PDT
Monitoring
High latency resulting in slower access to Box has been resolved since 1 PM PDT. Our teams will continue to monitor. If you are experiencing issues, please contact us at https://support.box.com.
Posted about 2 years ago. Mar 30, 2015 - 13:14 PDT
Investigating
Some users may be experiencing high latency resulting in slower access to Box and a message stating "Please refresh." Box Teams are currently investigating to restore full stability.
Posted about 2 years ago. Mar 30, 2015 - 12:31 PDT
This incident affected: Box Website and Box Notes.