Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

[RESOLVED] Collaborations Page In The Web Application Not Accessible for Some Users
Incident Report for Box
Resolved
Collaboration page not displaying has been fully resolved for impacted customers and we have not seen any further problems. If you are experiencing issues, please contact us at https://support.box.com.
Posted almost 2 years ago. May 11, 2015 - 17:27 PST
Monitoring
A fix was rolled out which addresses this problem. We will continue to monitor. If you experience any issues accessing the Collaborations Page in the Box Web Application, please contact us at https://support.box.com.
Posted almost 2 years ago. May 11, 2015 - 14:16 PST
Identified
A fix will be rolled out later today to address the issue of some users being unable to access the Collaborations Page in the Box Web Application.
Posted almost 2 years ago. May 11, 2015 - 12:49 PST
Investigating
Some users may be experiencing an error "Sorry we can't access that page" when attempting to access the collaborations page in the Box Web Application. We are actively investigating.
Posted almost 2 years ago. May 11, 2015 - 08:30 PST
This incident affected: Box Website and Sharing.