Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Some users may have experienced latency issues to Box
Incident Report for Box
Resolved
The monitoring period for this issue has ended and no further impact has been observed. Please report any outstanding issues to Box User Services via https://community.box.com/help
Posted about 1 year ago. Aug 19, 2016 - 12:07 PDT
Monitoring
Some users may have experienced latency issues with Box services, including uploads, downloads, and API calls, between 10:57 - 11:31am Pacific today. Our engineering team has stabilized the issue and is monitoring to ensure no further impact.
Posted about 1 year ago. Aug 19, 2016 - 10:57 PDT
This incident affected: Box Website, Content API, Downloads, and Uploads.