Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Some users may be experiencing issues with Box Notes, Uploads, Downloads
Incident Report for Box
Resolved
No further impact has been observed by our engineering team. If you continue to experience any issues, please contact Box User Services via community.box.com.
Posted 7 months ago. Oct 04, 2016 - 08:43 PDT
Monitoring
Our engineering team has stabilized affected services and will continue to monitor performance to ensure no further impact.
Posted 7 months ago. Oct 04, 2016 - 08:19 PDT
Investigating
Some Box users may be experiencing intermittent issues opening and loading Box Notes, as well as uploading and downloading files to/from Box. Box engineers are currently investigating the issue.
Posted 7 months ago. Oct 04, 2016 - 07:50 PDT
This incident affected: Box Notes, Downloads, and Uploads.