On October 1, 2018 Box changed the methodology for sharing service updates to include issues with minor customer impact in an effort to provide greater transparency and faster notifications. Read about the changes here...

[Minor] Issues with File Previews, Uploads, and Downloads
Incident Report for Box
Resolved
This issue is now considered resolved. If you continue to have issues previewing, uploading, or downloading content with box please contact us at https://support.box.com
Posted 3 months ago. Feb 18, 2019 - 08:03 PST
Monitoring
This issue is now considered resolved and we are continuing to monitor the affected services. If you continue to have issues previewing, uploading, or downloading content with box please contact us at https://support.box.com
Posted 3 months ago. Feb 18, 2019 - 06:55 PST
Investigating
We are currently investigating an issue beginning around 4:25 AM PST. Users may have issues previewing files in the Box Web Application or generating previews with the Box API. Users may also experience issues with uploads and downloads. We will provide updates here as soon as possible.
Posted 3 months ago. Feb 18, 2019 - 05:04 PST
This incident affected: Box Platform / API (Content Preview), Mobile Applications (Preview, Uploads/Downloads), and Box Web Application (Uploads/Downloads, Preview).