For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

[Major] Customers may experience issues uploading new documents to Box Sign
Incident Report for Box
Postmortem

We recently addressed issues affecting Box Sign. We would like to take the opportunity to further explain these issues and the steps we have taken to keep them from happening in the future.

Between 11:00 AM PT and 1:21 PM PT on April 7, 2023, some users may have experienced difficulties while working in Box. During this time, Box Sign users were unable to start the signing process using the upload new file feature. Users were presented with an error banner when uploading new documents. The issue occurred as a result of a recent code change made to standardize error code messages, which inadvertently impacted an internal interaction. We were able to resolve the issue by rolling back the relevant change. In addition, we have identified several corrective actions, detailed below, to minimize the likelihood of similar issues occurring in the future. 

Analysis

As part of an effort to standardize error codes returned in API responses, we rolled out a change that updated some existing codes. This change impacted an internal interaction, in the Box Sign document upload flow, that was explicitly relying on a prior error code value. When the relevant error situation arose, the code was unable to detect and mitigate the recoverable error, resulting in it being propagated out to the end-user in the form of an error banner.

Corrective Actions

The following corrective actions have been completed or are planned:

  • Added additional tests to prevent modifications of existing error codes until it is deemed safe to do so.
  • Started the process to deprecate custom error code values, only keeping the standardized HTTP response codes.
  • Augmenting continuous end-to-end testing on pre-production environments for increased observability around critical user journeys.

We are continuously working to improve Box and want to make sure we are delivering the best product and user experience we can. We hope we have provided some clarity here and we would be happy to answer any questions you may still have regarding this matter. 

Sincerely,

The Box Team

Posted Apr 19, 2023 - 15:59 PDT

Resolved
After further monitoring, this incident is now considered resolved. Box Sign has been restored to full functionality. If you continue to experience any issues, please contact Box Support at https://support.box.com.
Posted Apr 07, 2023 - 14:00 PDT
Monitoring
Our team has taken steps to remediate this issue and we are seeing improvement for Sign uploads. We are continuing to monitor for any additional impact during this time. We will provide the next update by 2PM PST 4/7.
Posted Apr 07, 2023 - 13:27 PDT
Identified
Our team has identified the underlying cause of this issue and is working to take remediating steps. We will provide the next update as soon as possible.
Posted Apr 07, 2023 - 13:22 PDT
Update
We are continuing to investigate this issue.
Posted Apr 07, 2023 - 13:06 PDT
Investigating
We are investigating an ongoing issue affecting uploading new documents to Box Sign. We will provide more information as soon as it is available.
Posted Apr 07, 2023 - 13:05 PDT
This incident affected: Box Web Application (Box Sign).