Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Some Users May Experience Issues Logging into Box
Incident Report for Box
Resolved
The DNS provider has updated that they have their services up and running again. As a result, Box service should be back to normal. If you continue to experience any issues, please contact Box User Services via community.box.com
Posted 7 months ago. Oct 21, 2016 - 06:59 PDT
Identified
A global event is affecting an upstream DNS provider. Box services may be intermittently available at this time.
Posted 7 months ago. Oct 21, 2016 - 06:33 PDT
This incident affected: Box Website.