On October 1, 2018 Box changed the methodology for sharing service updates to include issues with minor customer impact in an effort to provide greater transparency and faster notifications. Read about the changes here...

[Minor] Issues with Uploads
Incident Report for Box
Resolved
We have completed our extended monitoring period and we are considering the issue resolved. If you experience new issues with uploads, please contact us at https://support.box.com
Posted 5 months ago. Oct 30, 2018 - 20:47 PDT
Monitoring
We are currently monitoring to ensure no further impact is observed. If you are still seeing upload issues, please reach out at https://support.box.com.
Posted 5 months ago. Oct 30, 2018 - 19:39 PDT
Identified
We have identified the cause of the issue and upload services fully recovered by approximately 06:50 PM Pacific. While there is no current impact, we are actively taking steps to ensure that the issue does not recur.
Posted 5 months ago. Oct 30, 2018 - 19:12 PDT
Investigating
We are currently investigating an issue with uploads, beginning at approximately 06:30 PM Pacific. We will provide updates as soon as possible.
Posted 5 months ago. Oct 30, 2018 - 19:06 PDT