On October 1, 2018 Box changed the metholodoly for sharing service updates to include issues with minor customer impact in an effort to provide greater transparency and faster notifications. Read about the changes here...

[Minor] Issues with Custom Logos and Avatars in the Web Application
Incident Report for Box
Resolved
The monitoring period has ended and we are considering the issue resolved. If you experience further issues with custom logos and/or user avatars, please let us know at: https://support.box.com.
Posted 24 days ago. Oct 22, 2018 - 15:45 PDT
Monitoring
We have fixed the issues with custom logos and user avatars. We are currently monitoring for any further impact.
Posted 24 days ago. Oct 22, 2018 - 15:12 PDT
Identified
We have identified the cause of the custom logo and user avatar issues and are working on remediating the impact as fast as possible. The next update will be provided in an hour or when we can confirm recovery from the issue.
Posted 24 days ago. Oct 22, 2018 - 14:58 PDT
Update
We are continuing to investigate the issues with custom logos and user avatars in the web application, app gallery, and Box Notes. We will provide an update in an hour or at the next change in status.
Posted 24 days ago. Oct 22, 2018 - 13:55 PDT
Update
We are continuing to investigate the issues with logos and user avatars. In addition to custom branded enterprise logos and user avatars, there is also impact to logos on Box's application gallery. Users will see a generic icon or broken image link in the application gallery. We will provide another update in one hour or at the next change in status.
Posted 24 days ago. Oct 22, 2018 - 12:36 PDT
Update
We're continuing to investigate the issues with custom logos and avatars. We will provide another update in one hour or at the next change in status.
Posted 24 days ago. Oct 22, 2018 - 11:43 PDT
Update
We're continuing to investigate the issues with custom logos and avatars, and we will provide an update as soon as possible.
Posted 24 days ago. Oct 22, 2018 - 10:34 PDT
Investigating
We are continuing to investigate the issue with loading custom logos and avatars in the Web Application and Box Notes. Additionally, custom enterprise logos displayed in Content API previews will display the same behavior. We will provide another status update as soon as possible.
Posted 24 days ago. Oct 22, 2018 - 09:45 PDT
Identified
We have identified an issue with loading custom logos in the Web Application and avatars in Box Notes. Affected users will see a generic icon or broken image link. We will provide another update as soon as possible.
Posted 24 days ago. Oct 22, 2018 - 08:30 PDT
This incident affected: Box Notes (Web Application, Desktop Client), Box Platform / API (Content Preview), and Box Web Application (Admin Console & Functionality).