Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Issue Adding New Folder Access to Groups in Admin Console
Incident Report for Box
Resolved
Box Engineers have restored the ability to provide new folder access to groups in the Admin Console. Please report any further issues to us at https://support.box.com.
Posted over 2 years ago. Jan 09, 2015 - 11:47 PST
Identified
Admins & Co-admins are currently unable to add new folder access to groups in their Admin Console. Folders beneath "All Files" are not visible. An error also may be returned stating: "You cannot add collaborators to your root folder. Please select a folder you would like to add collaborators to." Box Engineers are actively working to restore this ability as soon as possible.
Posted over 2 years ago. Jan 08, 2015 - 18:30 PST
This incident affected: Box Website.