Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Some customers unable to access files.
Incident Report for Box
Resolved
This incident has been resolved.
Posted almost 3 years ago. Sep 10, 2014 - 15:09 PDT
Monitoring
Some users may have experienced degraded service from 12:56pm - 1:06pm PDT.
Posted almost 3 years ago. Sep 10, 2014 - 13:10 PDT
This incident affected: Box Website, Box Notes, Box Sync, Content Preview, Content API, View API, Downloads, Uploads, Email Notifications, Search, Sharing, and Mobile.