Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Uploads and Downloads Degraded
Incident Report for Box
Resolved
Since 5:10pm PDT, the degraded performance on uploads and downloads has been resolved.
Posted over 2 years ago. Oct 03, 2014 - 17:10 PST
Investigating
Starting around 4:35pm PDT some customers may be experiencing degraded performance on uploads and downloads.
Posted over 2 years ago. Oct 03, 2014 - 16:35 PST
This incident affected: Content Preview, Downloads, and Uploads.