Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Box services degraded
Incident Report for Box
Resolved
This incident has been resolved.
Posted about 3 years ago. Oct 22, 2014 - 12:40 PDT
Monitoring
Some Box services may have been degraded for some users between 11:17AM - 11:30AM PDT. Box services are currently functioning properly.
Posted about 3 years ago. Oct 22, 2014 - 12:33 PDT
This incident affected: Content Preview, Content API, View API, Downloads, and Uploads.