Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Downloads degraded
Incident Report for Box
Resolved
As of 3:59pm PDT, we've resolve the issue regarding degraded downloading performance.
Posted over 2 years ago. Oct 24, 2014 - 16:00 PDT
Monitoring
As of 2:00pm PDT, no customer impact was conclusively found during investigation. Currently monitoring the degraded downloading performance.
Posted over 2 years ago. Oct 24, 2014 - 14:07 PDT
Investigating
As of 12:00pm PDT, some users may experience degraded service when downloading files. We're currently investigating.
Posted over 2 years ago. Oct 24, 2014 - 13:21 PDT
This incident affected: Downloads.