Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Slower content previews.
Incident Report for Box
Resolved
Between 11:47 AM and 12:50 PM PDT, users may have experienced slowness with Content Preview on recently uploaded content. The issue has been confirmed as resolved.
Posted almost 3 years ago. Oct 20, 2014 - 15:05 PDT
Monitoring
As of 12:50pm PDT the issue with slower content preview is resolved. We will continue to monitor.
Posted almost 3 years ago. Oct 20, 2014 - 12:50 PDT
Investigating
As of 11:47AM PDT, some customers may be experiencing slower content previews on recently uploaded content. We're currently investigating.
Posted almost 3 years ago. Oct 20, 2014 - 11:47 PDT
This incident affected: Content Preview.