Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Degraded Performance :: Content Preview and Workflow
Incident Report for Box
Resolved
Content Preview and Workflow issues have been resolved as of 9:15PM PDT.
Posted over 2 years ago. Oct 13, 2014 - 21:15 PST
Investigating
As of 6:14PM PDT, Content Preview and Workflow began experiencing degraded performance. We are actively working to resolve these issues.
Posted over 2 years ago. Oct 13, 2014 - 18:14 PST
This incident affected: Content Preview.