Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Degraded Performance :: Uploads
Incident Report for Box
Resolved
The issue regarding uploads has been resolved as of 2:21 PM PDT. We apologize for any inconvenience.
Posted about 3 years ago. Sep 23, 2014 - 14:21 PDT
Investigating
Some users may be experiencing problems uploading large files. We are currently investigating.
Posted about 3 years ago. Sep 23, 2014 - 09:06 PDT
This incident affected: Uploads.