Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Uploads/Downloads degraded
Incident Report for Box
Resolved
This incident has been resolved.
Posted over 2 years ago. Oct 09, 2014 - 16:39 PST
Monitoring
Uploads and downloads have returned to normal as of 3:10pm PDT. We apologize for any inconvenience
Posted over 2 years ago. Oct 09, 2014 - 15:10 PST
Investigating
Uploads and downloads may be degraded for some users.
Posted over 2 years ago. Oct 09, 2014 - 14:25 PST
This incident affected: Downloads and Uploads.