Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Slower downloads
Incident Report for Box
Resolved
This incident has been resolved.
Posted over 2 years ago. Oct 14, 2014 - 18:07 PDT
Update
As of 4pm PDT the issue with slow downloads is resolved. We will continue to monitor the issue.
Posted over 2 years ago. Oct 14, 2014 - 16:10 PDT
Investigating
As of 9:30AM PDT, some customers may be experiencing slower downloads. We're currently investigating.
Posted over 2 years ago. Oct 14, 2014 - 09:30 PDT
This incident affected: Downloads.