Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Content preview may be degraded for some users.
Incident Report for Box
Resolved
The issue with Content Preview has been resolved as of 8:16pm PDT.
Posted almost 3 years ago. Oct 01, 2014 - 20:16 PDT
Update
The issue with Content Preview has been resolved as of 8:16pm PDT.
Posted almost 3 years ago. Oct 01, 2014 - 20:16 PDT
Investigating
Content preview may be degraded for some users, as of 6:00pm PDT.
Posted almost 3 years ago. Oct 01, 2014 - 18:00 PDT
This incident affected: Content Preview.