Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Anonymous users may have difficulty accessing some publicly shared files
Incident Report for Box
Resolved
12:39 PM PDT Shared links are working again.
Posted over 2 years ago. Oct 29, 2014 - 12:52 PDT
Investigating
At approximately 11:04 AM PDT customers began reporting that some anonymous users are having difficulty accessing publicly shared files. We are currently investigating.
Posted over 2 years ago. Oct 29, 2014 - 11:04 PDT
This incident affected: Box Website, Downloads, and Sharing.