Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Some free users may see an error when attempting to upgrade
Incident Report for Box
Resolved
We have rolled out the fix. Free users should be able to upgrade their accounts without issue.
Posted over 2 years ago. Oct 22, 2014 - 19:16 PST
Identified
Some free users may see an error when attempting to upgrade. We're currently rolling out a fix.
Posted over 2 years ago. Oct 22, 2014 - 18:57 PST
This incident affected: Box Website.